Symfony - debug a profiler toolbar se nezobrazuje

Autor Banán
Publikováno 06.04.2021
Kategorie programovani
Stav Vyřešeno
Dobrý den,

přestal se mně v Symfony zobrazovat toolbar s profiler a s debugem. Vůbec si neuvědomuji, co jsem v poslední době měnil. Může mně někdo poradit co zkontrolovat, aby se mi zase Symfony profiler toolbar zobrazoval?

Díky


Odpovědi na dotaz 6

The English language is translated by machine - the translator can modify eg cited codes = it is better to use codes from the Czech original.

Symfony - debug and profiler toolbar is not displayed

Hi,

I stopped seeing the profiler and debug toolbar in Symfony. I don't even realize what I've been changing lately. Can anyone advise me what to check to see the Symfony profiler toolbar again?

Thanks

RE: Symfony - debug a profiler toolbar se nezobrazuje

Autor Strosmajer
Publikováno 21.05.2021
Kategorie programovani
Stav Zkontrolováno
Dobrý den,

pokud se v Symfony přestal zobrazovat toolbar s profiler a s debugem, tak proveďte min. tuto kontrolu nastavení:


framework.yaml
------------------------------------------------------------------------
profiler:
enabled: true
collect: true


Co se týče logů tak zkuste změnit APP_ENV na dev v souboru .env
------------------------------------------------------------------------
APP_ENV=dev


Nastavní monolog.yaml pro dev je:
------------------------------------------------------------------------

monolog:
handlers:
main:
type: stream
path: "%kernel.logs_dir%/%kernel.environment%.log"
level: debug
channels: ["!event"]

console:
type: console
process_psr_3_messages: false
channels: ["!event", "!doctrine", "!console"]


6

The English language is translated by machine - the translator can modify eg cited codes = it is better to use codes from the Czech original.

Symfony - debug and profiler toolbar is not displayed

Hello,

if the toolbar with profiler and debug stopped appearing in Symfony, do min. this setting check:

framework.yaml
------------------------------------------------------------------------
profiler:
enabled: true
collect: true


As for the logs, try changing APP_ENV to dev in the .env file
------------------------------------------------------------------------
APP_ENV=dev


monolog.yaml for dev:
------------------------------------------------------------------------

monolog:
handlers:
main:
type: stream
path: "%kernel.logs_dir%/%kernel.environment%.log"
level: debug
channels: ["!event"]

console:
type: console
process_psr_3_messages: false
channels: ["!event", "!doctrine", "!console"]

Tento web používá k poskytování služeb, personalizaci reklam a analýze návštěvnosti soubory cookie. Používáním tohoto webu s tím souhlasíte. Další informace